On Saturday, June 20, 2015 at 4:15:30 AM UTC+1, Sean Corfield wrote:
>
>         (.getTypeName (Class/forName "[Ljava.lang.String;")) 
>         ;;=> "java.lang.String[]" — that is more readable! 
>

Thanks, that's helpful for me.  By chance do you know if the class is 
natively recoverable from the TypeName for Clojure/Java?  Class/forName 
can't roundtrip that string.  I could implement a look-up table to 
translate between the two formats, but that seems rather kludgey.

-- 
You received this message because you are subscribed to the Google
Groups "Clojure" group.
To post to this group, send email to clojure@googlegroups.com
Note that posts from new members are moderated - please be patient with your 
first post.
To unsubscribe from this group, send email to
clojure+unsubscr...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/clojure?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"Clojure" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to clojure+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to