On Jun 20, 2015, at 3:58 AM, Joe Corneli <holtzerman...@gmail.com> wrote:
> On Saturday, June 20, 2015 at 4:15:30 AM UTC+1, Sean Corfield wrote:
>         (.getTypeName (Class/forName "[Ljava.lang.String;")) 
>         ;;=> "java.lang.String[]" — that is more readable! 
> 
> Thanks, that's helpful for me.  By chance do you know if the class is 
> natively recoverable from the TypeName for Clojure/Java?  Class/forName can't 
> roundtrip that string.

I’m not sure what you mean?

The type of the array displays as [Ljava.lang.String; and when you do 
Class/forName on "[Ljava.lang.String;" you get back a Class that represents an 
array of String. The TypeName is just a human-readable form, not an actual 
Class name.

Sean Corfield -- (904) 302-SEAN
An Architect's View -- http://corfield.org/

"Perfection is the enemy of the good."
-- Gustave Flaubert, French realist novelist (1821-1880)



-- 
You received this message because you are subscribed to the Google
Groups "Clojure" group.
To post to this group, send email to clojure@googlegroups.com
Note that posts from new members are moderated - please be patient with your 
first post.
To unsubscribe from this group, send email to
clojure+unsubscr...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/clojure?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"Clojure" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to clojure+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to