Gerhard Froehlich wrote:
>
> >is there any reason why the keys() method of the MRUStore is
> >not implemented?
> Laziness, forgetfulness :). Will be corrected.

Great!
> >The returned enumeration should contain all keys of the cache
> >and the underlying fs store, right?
> Can be very slow when there are many objects on the fs....
Indeed, but usually clients of the Store rarely need to call this
method and if they do it's their fault...But it should be implemented
regardless of performance issues.

> >In addition is the implementation if the containsKey() method
> >correct? It checks only against the memory cache but not
> >against the filesystem.
> The problem is, that to much fs I/O can react negative on the performance.
> Because of that containsKey() only checks the memory...But you're
> right this is in-consistent.
I would rather call it wrong ;) Will you please fix this, too?

Cheers,
Carsten
>
> The current algorithm checks the fs in the get(..) method.
>
> Cheers
> Gerhard
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [EMAIL PROTECTED]
> For additional commands, email: [EMAIL PROTECTED]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to