Hi Team,

last week we agreed on moving the authentication and portal
components from the scratchpad into the main area.
For this we have to remove the sun*** names from the components.

It seems that the "functionality" approach is the way to go,
so the packages should be named "authentication" and "portal".
We then have the basic session functionality of sunShine which
could go into a package named "session", so we would end up
with:

org.apache.cocoon.session
org.apache.cocoon.authentication
org.apache.cocoon.portal

For us this is fine, but I see the problem with many package names
directly located under org.apache.cocoon. As all these packages
- and I believe some new ones like form handling, too - can be seen 
as optional packages, I would like to add a deeper hierarchy like:

org.apache.cocoon.SOMETHING.session
org.apache.cocoon.SOMETHING.authentication
org.apache.cocoon.SOMETHING.portal
org.apache.cocoon.SOMETHING.forms
...

Now, the question is, how do we name "SOMETHING". I first thought of
"module", but this could get soon confusing with blocks. So currently
I'm prefering "framework" which would then look like this:

org.apache.cocoon.framework.session
org.apache.cocoon.framework.authentication
org.apache.cocoon.framework.portal
org.apache.cocoon.framework.forms

But on the other hand "framework" is not very descriptive...

So, what do you think of creating this extra layer and what could be 
a good (short) name for this package?

Cheers
Carsten

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to