On Wed, 4 Dec 2002, Stefano Mazzocchi wrote:

> I think Sylvain has a point. I'm not sure I like 'sendPageAndReturn'
> that much, but it's true that 'sendPage' contains less semantic meaning
> than 'sendPageAndWait' and therefore might become a little confusing at
> first. It's a little bit semantically unbalanced and this doesn't
> reflect in their functional operation.
>
> So, let's see, that method is supposed to 'send a page' to the client
> but is not going to wait for the client to come back and continue. So,
> the real name would be something like
>
>   - sendPageAndDontWait
>
> but that sucks.
>
>   - sendPageAndReturn
>
> is nice but only if you understand that the flow layer takes control
> over the sitemap and that 'return' means that you are returning from
> procedural continuation-based control (the flowscript) to declerative
> request driven control (the sitemap)
>
> So it does have perfect sense for us, but I'm not sure it does for
> somebody that looks at the flowscript for the first time.
>
> But I can't come up with anything better because
>
>   - sendPageAndExit
>
> might be even worse (people might think Cocoon might stop!)
>
> Any idea?

As you said above the function does two things:

  1. send a page
  2. does not wait

So, how about splitting it into two function:

  - sendPage
  - getAnswer

Giacomo


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to