[
https://issues.apache.org/jira/browse/BEAM-370?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15785974#comment-15785974
]
Ben Chambers commented on BEAM-370:
-----------------------------------
Not yet -- there are still a few methods called ".named()" that should be
removed. Specifically, Combine#named still exists, and is used to provide nicer
default names for composite transforms such as Max.
https://github.com/apache/beam/blob/f62d04e22679ee2ac19e3ae37dec487d953d51c1/sdks/java/core/src/main/java/org/apache/beam/sdk/transforms/Max.java#L55
> Remove the .named() methods from PTransforms and sub-classes
> ------------------------------------------------------------
>
> Key: BEAM-370
> URL: https://issues.apache.org/jira/browse/BEAM-370
> Project: Beam
> Issue Type: Improvement
> Components: sdk-java-core
> Reporter: Ben Chambers
> Assignee: Ben Chambers
> Priority: Minor
> Labels: backward-incompatible
>
> 1. Update examples/tests/etc. to use named application instead of `.named()`
> 2. Remove the `.named()` methods from composite PTransforms
> 3. Where appropriate, use the the PTransform constructor which takes a string
> to use as the default name.
> See further discussion in the related thread
> (http://mail-archives.apache.org/mod_mbox/incubator-beam-dev/201606.mbox/%3ccan-7fgzuz1f_szzd2orfyd2pk2_prymhgwjepjpefp01h7s...@mail.gmail.com%3E).
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)