[
https://issues.apache.org/jira/browse/CASSANDRA-14761?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16642076#comment-16642076
]
Benedict commented on CASSANDRA-14761:
--------------------------------------
Where did the term 'backup' come from for this? I'm not sure I like it, as
this also has another meaning so it seems potentially confusing. We get to
define our nomenclature entirely now, so we should choose carefully.
What about {{rapid_write_protection_threshold}} (we could also deprecate
{{speculative_retry_threshold}} and replace with
{{rapid_read_protection_threshold}} for consistency, which is probably also
clearer and more consistent with our published nomenclature)
This could go with {{rapid_write_protections}} or
{{rapid_write_protection_count}}, and (eventually) {{transient_writes}} to
include _all_ writes to transient replicas (rapid or otherwise)?
> Rename speculative_write_threshold to something more appropriate
> ----------------------------------------------------------------
>
> Key: CASSANDRA-14761
> URL: https://issues.apache.org/jira/browse/CASSANDRA-14761
> Project: Cassandra
> Issue Type: Improvement
> Components: Core
> Reporter: Ariel Weisberg
> Assignee: Ariel Weisberg
> Priority: Major
> Fix For: 4.0
>
>
> It's not really speculative. This commit is where it was last named and shows
> what to update
> https://github.com/aweisberg/cassandra/commit/e1df8e977d942a1b0da7c2a7554149c781d0e6c3
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]