[
https://issues.apache.org/jira/browse/NIFI-309?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14369691#comment-14369691
]
Dan Bress commented on NIFI-309:
--------------------------------
Joe,
I'll cancel the PR, rebase, make the above changes, and submit a new one.
What is the suggestion exactly for DynamicProperties/DynamicProperty?
-rename DynamicProperty to Property?
-rename DynamicProperty.name() to value? - If I do this, I will have to rename
the current field named "value" to "valueDescription" which probably makes
sense. I wasn't thinking about the meaning of "value" in the context of an
Annotation
The reason why SeeAlso supports a Class<? extends ConfigurableComponent>[]
and a String[] is a lot of processors have SeeAlso's on things that are not in
their projects classpath(think DetectDuplicate wants you to look at
DistributedMapCacheClientService, but DistributedMapCacheClientService is not
in DetectDuplicates classpath. So you can't do a
DistributedMapCacheClientService.class). If you have a different idea here I'm
all for it.
> Support additional documentation annotations
> --------------------------------------------
>
> Key: NIFI-309
> URL: https://issues.apache.org/jira/browse/NIFI-309
> Project: Apache NiFi
> Issue Type: Improvement
> Components: Core Framework, Documentation & Website
> Affects Versions: 0.0.1
> Reporter: Dan Bress
> Assignee: Dan Bress
> Priority: Trivial
>
> Additional documentation only annotations should be added to better describe
> ConfigurableComponents. These annotations are:
> DynamicProperties - this would indicate whether a component supports dynamic
> properties or not, and provides a description. This could be used by the UI
> to determine whether or not to allow dynamic properties. It could also be
> reflected in the documentation.
> DynamicRelationships - this would indicate whether a component has dynamic
> relationships, like RouteOnAttribute and DistributeLoad do. This could be
> reflected in the documentation.
> ReadsAttribute - indicates what attributes a Processor reads certain FlowFile
> attributes on incoming FlowFiles. This would be reflected in the
> documentation.
> WritesAttribute - indicates what attributes a Processor creates on outgoing
> FlowFile attributes. This would be reflected in the documentation.
> SeeAlso - Provides a mechanism to link one configurable component to another.
> E.g. PutFile & GetFile. This would be used in the documentation.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)