[ 
https://issues.apache.org/jira/browse/NIFI-309?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14369890#comment-14369890
 ] 

Dan Bress commented on NIFI-309:
--------------------------------

*Discussion Points*

# Changing {{@ReadsAttributes(\{@ReadsAttribute\})}} to 
{{@ReadsAttributes(\{@Attribute\})}} 
and {{@WritesAttributes(\{@WritesAttribute\})}} to 
{{@WritesAttributes(\{@Attribute\})}}
and {{@DynamicProperties(\{@DynamicProperty\})}} to 
{{@DynamicProperties(\{@Property\})}}
# Changing {{@ReadsAttribute.attribute}} to {{@ReadsAttribute.value}} and 
{{@WritesAttribute.attribute}} to {{@WritesAttribute.value}}
{{@WritesAttribute(value = "filename", description = "The filename is set to 
the name of the file on disk")}}.  
# What should the UI do if {{@DynamicProperties}} are specified?
## Nothing, leave it like it is today
## Only allow them to add dynamic properties if the annotation is specified
## Display a warning if they attempt to add a dynamic property when the 
annotation is not specified
# Rename {{@DynamicProperty.value}} to {{@DynamicProperty.valueDescription}}

*Dan's Votes*
# Vote to leave as is
# Vote to leave as is
#* Vote to leave it as is because {{@WritesAttribute(attribute = "filename", 
description = "The filename is set to the name of the file on disk")}} is more 
clear to me than {{@WritesAttribute(value = "filename", description = "The 
filename is set to the name of the file on disk")}}, since use of Reads/Writes 
attributes specifies a description which means you have to specify value.
# Vote for Option 3
# Vote for change to valueDescription

> Support additional documentation annotations
> --------------------------------------------
>
>                 Key: NIFI-309
>                 URL: https://issues.apache.org/jira/browse/NIFI-309
>             Project: Apache NiFi
>          Issue Type: Improvement
>          Components: Core Framework, Documentation & Website
>    Affects Versions: 0.0.1
>            Reporter: Dan Bress
>            Assignee: Dan Bress
>            Priority: Trivial
>
> Additional documentation only annotations should be added to better describe 
> ConfigurableComponents.  These annotations are:
> DynamicProperties - this would indicate whether a component supports dynamic 
> properties or not, and provides a description.  This could be used by the UI 
> to determine whether or not to allow dynamic properties.  It could also be 
> reflected in the documentation.
> DynamicRelationships - this would indicate whether a component has dynamic 
> relationships, like RouteOnAttribute and DistributeLoad do.  This could be 
> reflected in the documentation.
> ReadsAttribute - indicates what attributes a Processor reads certain FlowFile 
> attributes on incoming FlowFiles.  This would be reflected in the 
> documentation.
> WritesAttribute - indicates what attributes a Processor creates on outgoing 
> FlowFile attributes.  This would be reflected in the documentation.
> SeeAlso - Provides a mechanism to link one configurable component to another. 
>  E.g. PutFile & GetFile.  This would be used in the documentation.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to