[
https://issues.apache.org/jira/browse/NIFI-309?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14369774#comment-14369774
]
Matt Gilman commented on NIFI-309:
----------------------------------
Only providing this option when the processor indicates it supports them seems
like an obvious fit. As a processor developer it would make sense that they
were linked, especially if other annotations were used within the controller
(as was previously suggested with the [read|write] attribute annotations I
believe) for some decision/hinting.
The question is whether we want to introduce a compatibility breaking change
(which we are already doing in 0.1.0).
> Support additional documentation annotations
> --------------------------------------------
>
> Key: NIFI-309
> URL: https://issues.apache.org/jira/browse/NIFI-309
> Project: Apache NiFi
> Issue Type: Improvement
> Components: Core Framework, Documentation & Website
> Affects Versions: 0.0.1
> Reporter: Dan Bress
> Assignee: Dan Bress
> Priority: Trivial
>
> Additional documentation only annotations should be added to better describe
> ConfigurableComponents. These annotations are:
> DynamicProperties - this would indicate whether a component supports dynamic
> properties or not, and provides a description. This could be used by the UI
> to determine whether or not to allow dynamic properties. It could also be
> reflected in the documentation.
> DynamicRelationships - this would indicate whether a component has dynamic
> relationships, like RouteOnAttribute and DistributeLoad do. This could be
> reflected in the documentation.
> ReadsAttribute - indicates what attributes a Processor reads certain FlowFile
> attributes on incoming FlowFiles. This would be reflected in the
> documentation.
> WritesAttribute - indicates what attributes a Processor creates on outgoing
> FlowFile attributes. This would be reflected in the documentation.
> SeeAlso - Provides a mechanism to link one configurable component to another.
> E.g. PutFile & GetFile. This would be used in the documentation.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)