Hi,
some nitpicking from me (currently trying to write a user guide for me):
why is
ReflectedPropertyIntrospector
not called
ReflectionPropertyInspector?
Would be a little bit clearer from my point of view, that objects of this
class are actively
doing something.
I do not like the names of ~Support classes. ~Support or ~Helper indicate
(for me)
that these are Helper classes with (often static) utility functions. In the
Java API I think
I have found the usage of Abstract~ or Base~ much more often for classes
like
the ~Support classes in Clazz. E.g.
ReflectedPropertyIntrospectorSupport
might be called
AbstractReflectedPropertyIntrospector or
BaseReflectedPropertyIntrospector
and to keep it consistent with my previous remark, it should be called:
AbstractReflectionPropertyIntrospector or
BaseReflectionPropertyIntrospector
I would easily agree that these are minor changes, but since I have such a
difficult
time understanding the framework, I just write down every single issue I
stumble
upon.
Regards
Victor
PS: more to come
---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]