If we have not succeeded in keeping things simple, we are certainly
open to improving documentation and / or providing wrappers or
simplified interfaces.  If you have specific examples / suggestions
for improvement, please share these.  We want to make the package as
easy to use a possible, while still maintaining extensibility.


Well, I have indicated several things already, but all of them are put aside as "standard notation" or related arguments....

Nothing has been "put aside." We make decisions by consensus. You have provided input and we are considering it. To make sure I have it all right, you have proposed four changes:


1) Change the RealMatrix getEntry, getRow, getColumn methods to use 0-based indexing.

2) Change the name of "BivariateRegression" to "UnivariateRegression" (or something else)

3) Change Variance to be configurable to generate the population statistic.

4) Combine the univariate and multivariate packages, since it is confusing to separate statistics that focus on one variable and sometimes the word "univariate" is used in the context of multivariate techniques (e.g. "Univariate Anova").

My personal opinion is that none of these changes should be implemented, but if consensus is that we should stop the release and make these changes, then we will do that. In the case of 3), I would strongly suggest that if we really see this as necessary, we add a new statistic (as we will with remedian) instead of trying to force one univariate to compute two statistics (which runs counter to the design of the package).

Did I capture your suggestions correctly? Is there anything else that you find confusing or hard to use?

Thanks again for your feedback.

It would be great if other [math] committers could weigh in with simple yes / no on each of the proposed changes above so that we can move forward with the release.

Phil


Kim



---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Reply via email to