On Tue, Feb 3, 2009 at 11:58 AM, Olivier Migeot <larry...@gmail.com> wrote:

> I've just tried the image on my SD card (no qi, then, I guess), and if
> fails all the same.

Ok, I tried again (my FR's battery being depleted in the meantime),
and here's the results. My FR is using uBoot, boots nicely on the
internal flash (on which there is FSO M4.1) and used to boot nicely on
the SD card (at least with the previous milestone). I fetched both a
tarball [1] of M5 and a kernel [2]. I expanded the tarball in
/media/mmcblk0p2/ (as it is mounted on M4.1) after making sure the
said filesystem was empty. I then moved my freshly downloaded kernel
image into /media/card/uImage.bin (should be the first partition of
the SD card, IIRC).

>From there, I both tried to boot the SD card from the NAND and NOR
menus, and each time it ends up being unable to write anything on the
filesystem (eventually failing to launch X), which sounds pretty
similar to the Qi problem described here.

Would anyone have an idea on how to fix that? There should be a way to
explain uBoot how to deal with this, but I don't know it yet...


[1] openmoko-fso-image-glibc-ipk--20090202-om-gta02.rootfs.tar.gz


Openmoko community mailing list

Reply via email to