Hello FreeRunners,

I am still using QtMoko v14 in onboard NAND on my US GTA02A6.  I know 
v16 is old by now, but I am not upgrading because it is a huge hassle. 
I already upgraded from v11 to v14 months ago;  I do not want to repeat 
that hassle.  I will have even more to do after upgrading from v14 than 
from v11 because I have many customisations to restore and packages to 
reinstall.  Anyway, when I was still living in my parents’s house, I had 
the USB networking working with Windows Vista Ultimate Edition SP1 
32-bit on optiplex960.  My QtMoko had reliable Internet access via the 
network bridge (Local Area Connection + Neo Connection).  I upgraded 
from Windows Vista SP1 to SP2 because I wanted full support for 
RealTimeIsUniversal=1.  I do not remember testing the USB networking 
after upgrading to SP2, so maybe it broke with SP2.  I finally chose a 
model of laptop, ordered it, and received it.  brolin-V13 (my laptop) 
runs Windows 7 Professional 32-bit.  The USB networking is intermittent 
with Windows 7:  I can ssh to QtMoko from Cygwin on brolin-V13, but 
QtMoko can only partially access the Internet.  Name resolution works 
sometimes, but most of the time I get “destination host unreachable” 
when pinging hosts on my LAN or on the Internet.  Sometimes, though, the 
pings start working, but I do not know why and I cannot reliably 
reproduce the behaviour.  I tried USB networking with optiplex960 again 
since it used to work there, but QtMoko cannot access the Internet 
because I get “destination host unreachable” when pinging hosts on my 
LAN or on the Internet.  Actually, I do not fully remember what happened 
because it was weeks ago and I did not keep a log.  I know I should have 
asked for help on this list then, but I was trying to be practical and 
avoid sidetracking by using what works and not bothering asking for help 
with what I cannot get working (USB networking with Windows Vista + 
Windows 7).  I cannot connect my QtMoko to my WLAN because the QtEI WLAN 
GUI does not work properly and using the command line is too much 
hassle:  sometimes it works, other times it does not, but I do not even 
know what is different between when it works and does not work.  So, 
other than using sneakernet to transfer files to my FreeRunner, the only 
reliable network connection is my USB→Ethernet adapter.  I had a miniUSB 
M→USB AF adapter connected directly to my FreeRunner (not using a long 
cable, which I should have done as I discovered later, after it was too 
late), then my dual-power USB hub, then my USB→Ethernet adapter, then an 
Ethernet cable to my USB→Ethernet adapter.  This worked for a day or so, 
but I think it was a mistake because there was too much weight on the 
miniUSB M→USB AF adapter while I was holding my FreeRunner to use it for 
voice calls.  Now my FreeRunner’s USB port works for power, so I can 
still charge the battery, but not for communications, so I think a 
solder connection must have come undone.  I need to try disassembling my 
FreeRunner to check the connections for the USB connector so I can ask 
someone at work to fix (resolder) the connection, but I have not yet 
done so.  It must be a hardware problem because QtMoko can still charge, 
but nothing happens when I connect USB devices to my FreeRunner:  no 
kernel modules are automatically loaded, there are no kernel messages. 
Manually loading the kernel modules (e.g., dm9601 for my USB→Ethernet 
adapter) for the USB device does not help.  It is not because of the 
electrical/logical USB host/device setting because I checked that;  I 
know how to use sysfs to change it.

Does anyone use USB networking with their FreeRunner with Windows Vista 
or Windows 7?  I do not want to uninstall Windows Vista SP2 on 
optiplex960 because I want full support for RealTimeIsUniversal=1. 
There is nothing I can do with Windows 7 because no service pack has 
even been released.  I have Ubuntu v8.04 LTS on k7t266 at home, but even 
if I could get USB networking working with k7t266, that does not help 
when I am at work because k7t266 (+ optiplex960) stay(s) on my desk at 
home.  I want reliable USB networking with Windows 7 on brolin-V13, but 
that does not even matter any more until I fix the USB port hardware 
problem.  I am not running Linux or any other OS on brolin-V13 because I 
highly prefer Windows Vista or Windows 7 over Linux (Ubuntu) as a 
desktop client OS.  I do not want to debate this preference.

Oh well, at least I think I finally have satisfactory earpiece volume on 
my QtMoko, at least when there is no or little background noise.  I can 
live with using the Docked Keyboard in qterminal, but now I cannot even 
ssh to QtMoko, never mind reflash nor access the Internet from QtMoko. :(


Sometimes I forget how to do small talk: <http://xkcd.com/222/>

“If you have to ask why, you’re not a member of the intended audience.” 
— Bob Zimbinski, <http://webpages.mr.net/bobz/ttyquake/>

Openmoko community mailing list

Reply via email to