On Tue, 10 May 2022 20:45:02 GMT, Vladimir Ivanov <vliva...@openjdk.org> wrote:

>> Jorn Vernee has updated the pull request with a new target base due to a 
>> merge or a rebase. The pull request now contains 21 commits:
>> 
>>  - Merge branch 'foreign-preview-m' into JEP-19-VM-IMPL2
>>  - Remove unneeded ComputeMoveOrder
>>  - Remove comment about native calls in lcm.cpp
>>  - 8284072: foreign/StdLibTest.java randomly crashes on MacOS/AArch64
>>    
>>    Reviewed-by: jvernee, mcimadamore
>>  - Update riscv and arm stubs
>>  - Remove spurious ProblemList change
>>  - Pass pointer to LogStream
>>  - Polish
>>  - Replace TraceNativeInvokers flag with unified logging
>>  - Fix other platforms, take 2
>>  - ... and 11 more: 
>> https://git.openjdk.java.net/jdk/compare/3c88a2ef...43fd1b91
>
> src/hotspot/cpu/x86/foreign_globals_x86_64.cpp line 52:
> 
>> 50: 
>> 51:   objArrayOop inputStorage = 
>> jdk_internal_foreign_abi_ABIDescriptor::inputStorage(abi_oop);
>> 52:   loadArray(inputStorage, INTEGER_TYPE, abi._integer_argument_registers, 
>> as_Register);
> 
> `loadArray` helper looks a bit misleading. In presence of `javaClass`-style 
> accessors, it misleadingly hints that it refers to some Java-level 
> operation/entity, though what it does it parses register list representation 
> backed by a Java array. I suggest to rename it to something like 
> `parse_argument_registers_array()`).

I went with `parse_register_array` (since it's also used for return registers)

-------------

PR: https://git.openjdk.java.net/jdk/pull/7959

Reply via email to