On Thu, 7 Sep 2023 12:02:02 GMT, Aleksey Shipilev <sh...@openjdk.org> wrote:
>> src/java.base/share/classes/jdk/internal/util/Architecture.java line 164: >> >>> 162: public static boolean isPPC() { >>> 163: return PlatformProps.TARGET_ARCH_IS_PPC; >>> 164: } >> >> Maybe `isPPC32()` would be a better name (also `PPC32` above). Note that >> hotspot uses `PPC` for all PPC platforms and has the more specific macros >> `PPC32` and `PPC64`. > > Yeah, we can technically change to `PPC32`. But the current thing follows > what build system uses as `OPENJDK_TARGET_CPU` (`ppc`) and what would be used > as `os.arch` because of that. So, choosing which way to deviate: towards > build-system/java-props or towards hotspot macros, I think what current PR > does is the lesser evil. One might expect `isPPC()` to return true on PPC64 because it technically is. This is the only drawback I see. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/15556#discussion_r1318550667