On Fri, 17 Jul 2026 16:50:51 GMT, Justin Lu <[email protected]> wrote:

> I think this name is correct. We are taking the Gregorian era and year and 
> convert it to the ISO proleptic year. That is how the converted java.time 
> classes refer to the year.

Okay, scratch that. 

We are just deriving the java.time value from the date's values for year, 
month, etc. Technically, the conversion to the ISO calendar system is not 
exact, since `GregorianCalendar` is a hybrid Julian-Gregorian calendar. 

We might better name it as `toGregorianProlepticYear`, which only indicates 
that the year and era are used to derive a Gregorian proleptic year (and not an 
exact ISO date conversion).

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/31808#discussion_r3604959336

Reply via email to