On Fri, 14 Aug 2026 13:38:12 GMT, Tatsunori Uchino <[email protected]> wrote:
>> src/java.base/share/classes/java/lang/String.java line 1939:
>>
>>> 1937: * @since 28
>>> 1938: */
>>> 1939: public int codePointCount() {
>>
>> The simpler/updated proposal looks good. The other methods that operate on
>> code points will use "unpaired surrogates" and I think we should do the same
>> here rather than switching to "Isolated surrogate code units".
>
> https://www.unicode.org/versions/Unicode17.0.0/core-spec/chapter-3/#G1654
>
> https://www.google.com/search?q=%22isolated+surrogate%22&domains=unicode.org&sitesearch=unicode.org
> https://www.google.com/search?q=%22unpaired+surrogate%22&domains=unicode.org&sitesearch=unicode.org
Unicode Core Spec adopts the term "Isolated surrogate code units".
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/26461#discussion_r3784141014