Milan Obuch writes:

Any ideas what to chceck? I deleted maildirsize in order to enforce quota recalculation, but no change. Where could this block be? Earlier today this maildir accepted mails, got approx. 60 % full, so mail sitting in queue did not fit, but later was emptied via pop3. Now every mail is rejected.

However, as I am writing this, first test message is being delivered, approx. 15 minutes after being sent (maybe retry from the other server, again, courier), one hour or so after mailbox got emptied.

So my question is, why took it so long to restore normal mail processing?

When a message fails with a temporary deferral code -- in this case it's because the mailbox is full -- Courier stops accepting any more mail to the mailbox. After all, it makes no sense to accept more mail for a full mailbox.

Emptying the mailbox does not automatically clear the block. After all, the delivery problem can have another reason. Once the message in the mail queue gets succesfully delivered to the mailbox, the block is cleared and mail will continue to be accepted again.

So, essentially, once a full mailbox is emptied mail delivery does not resume immediately, but only after the last message in the queue gets succesfully redelivered. It is impractical to recompute the quota on every attempt to accept mail from an external source.

There's also a failsafe timeout of two hours, in case someone does something silly, like remove the last message stuck in the mail queue.

This is not the end of the world. If someone lets their mailbox pile up until it's full, it'll take a little while for things to get moving again.

There's also a command to manually clear the block, but I'm not going to tell you what it is. It's documented in the manual pages. You should've read the documentation, which explains all of this.

Attachment: pgpWzPqpDxcsG.pgp
Description: PGP signature

Reply via email to