Thank you for your ideas!

I have made no changes but can't reproduce the issue today
both with a very short path of /usr/bin and the original path
I tried with VPN off or on
I would be happy to try a few other experiments - but I don't even need the
workaround of reverting to an older git

$ which git

$ git --version
git version 2.45.1

git clone -v

mv lxml lxml-
git clone -v

while rm -rf lxml && time git clone -v  ;
do date ; done

at the moment the above loop runs hundreds of times without errors

On Mon, May 27, 2024 at 1:31 PM Adam Dinwoodie <> wrote:

> I've just set up a test sandbox with the same set of Cygwin
> applications installed, and I'm still not able to replicate this
> failure, which is going to make it difficult to work out what's going
> wrong for you!
> I note your Cygwin PATH has several entries before /bin, including a
> ~/bin that apparently contains a perl executable; can you see if you
> can reproduce the problem with a clean PATH?
> In any case, I'm having to conclude the issue is something odd about
> your environment that doesn't seem to be affecting most people.
> Working out what's going wrong will probably require isolating what
> difference is relevant here. I think there's two obvious routes to
> doing that: you can work out what's odd about your environment (maybe
> use Windows Sandbox, given you're running Windows Enterprise? I've
> attached a .wsb file that should give you a starting point for setting
> up test environments, based on your cygcheck.out), or you can work out
> what's changed in Git between 2.42.0 and 2.45.1, which will probably
> mean building and bisecting Git yourself; once we know what change is
> the culprit, that'll make it much easier to work out what's going
> wrong.
> If it'd be useful, I can provide some test builds of Git to help
> narrow down where the problem is, but if you can do the builds
> yourself, that'll be a lot quicker than trying to do a binary chop by
> email…

Problem reports:
Unsubscribe info:

Reply via email to