Quoting Daniel Kahn Gillmor (2016-10-13 00:31:28)
> > On Wed, Oct 12, 2016 at 11:42:15PM +0200, Thomas Goirand wrote:
> >> gpg: Invalid option "--pinentry-mode"
> … it sounds like sbuild should at least have declared a versioned
> dependency on gnupg (>= 2.1), when --pinentry-mode was introduced.

this is indeed a real bug. Thanks for reopening this so that I don't forget to
handle this for my next upload.

> Alternately, maybe the requirement to run --keygen could be relaxed?

That would require some version detection mechanism I suppose. I don't think it
is useful to have sbuild in stable be able to run with old gnupg as the next
stable release will have the correct gnupg version available. So if the
requirement is relaxed, then it is purely useful for sbuild in backports. I
don't know if our current sbuild backporter Luca (in CC) would be willing to
write such a patch, especially considering that

 - it is a feature of sbuild since version 0.67.0 (I corrected the wiki page
   accordingly) to *not* require signing of the internal dummy repository (and
   thus you don't need to run sbuild-update --keygen anymore) and that
 - the next stable release is not far away.


cheers, josch

Attachment: signature.asc
Description: signature

Reply via email to