Package: libc6-dev
Version: 2.28-10
Severity: important

Until a few hours ago I run stable. Switching sources to testing and
apt-get update
apt-get upgrade

worked. Now:

apt-get dist-ugprade tells me the following:

root@samd:~# LC_ALL=C apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by 
held packages.

If I try to remove either libc6-dev or libgcc-8-dev then a long list of 
programms is scheduled for deinstallation, e.g. lots of KDE, okular, 
libreoffice etc.

-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel taint flags: TAINT_UNSIGNED_MODULE
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8) (ignored: LC_ALL 
set to de_DE.UTF-8), LANGUAGE=de_DE.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set 
to de_DE.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libc6-dev depends on:
ii  libc-dev-bin    2.28-10
ii  libc6           2.28-10
ii  linux-libc-dev  5.7.6-1

libc6-dev recommends no packages.

Versions of packages libc6-dev suggests:
ii  glibc-doc     2.30-8
ii  manpages-dev  5.07-1

-- no debconf information

      Dr. Helge Kreutzmann           
        64bit GNU powered                     gpg signed mail preferred
           Help keep free software "libre":

Attachment: signature.asc
Description: PGP signature

Reply via email to