control: tags -1 + help


On 2020-07-07 21:04, Helge Kreutzmann wrote:
> Package: libc6-dev
> Version: 2.28-10
> Severity: important
> Until a few hours ago I run stable. Switching sources to testing and
> then
> apt-get update
> apt-get upgrade
> worked. Now:
> apt-get dist-ugprade tells me the following:
> root@samd:~# LC_ALL=C apt-get dist-upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Calculating upgrade... Error!
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>  libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed
> E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by 
> held packages.

This break entry is correct, if we remove it gcc-8 will be left
potentially broken after the upgrade. I have no idea how it can be fixed
on the glibc side.

> If I try to remove either libc6-dev or libgcc-8-dev then a long list of 
> programms is scheduled for deinstallation, e.g. lots of KDE, okular, 
> libreoffice etc.

Have you tried installing gcc-defaults from testing before starting the


Aurelien Jarno                          GPG: 4096R/1DDD8C9B       

Attachment: signature.asc
Description: PGP signature

Reply via email to