Robert Marsellés:

> - "virtualbox" recomana "virtualbox-qt" així que d'aquest últim
> s'instal·la automàticament la versió que toca al canviar la versió del
> primer. En canvi,

Des de fa un temps, les recomanacions s'instal·len per defecte.
Ho pots desactivar posant això a l'apt.conf:

    APT::Install-Recommends "false";

> - "virtualbox" depen de "virtualbox-dkms" i, tot i això, s'ha
> d'instal·lar a mà la versió corresponent si no automàticament et quedes
> amb l'antiga.

Crec que és perquè virtualbox depèn de

    virtualbox-dkms (>= 5.1.6-dfsg-2) |
    virtualbox-source (>= 5.1.6-dfsg-2) |
    virtualbox-modules

Com que virtualbox-modules és un paquet virtual que proveeix
el virtualbox-dkms i ja tenies una versió del virtualbox-dkms
instal·lada, no l'ha actualitzat.

No tinc ni idea de si és una cosa buscada o si és un error que
el virtualbox-modules no tingui versió.

Salut,
Alex

Respondre per correu electrònic a