Quan estàs «amb el front dels usuaris» t'adones que la pràctica i la
teòrica no coincideixen.
La solució semblaria tant fàcil com fer cas a l'usuari: Que ha trucat al
servei de suport del departament de justícia, o del registre d'entrada
d'on sigui, i li han dir que descarregant-se tal programa.exe tot li
anirà a la primera.

A mi no em sembla malament deixar enrere la tecnologia dels Applets,
sinó que em sembla malament deixar enrere els usuaris dels Applets, i la
quantitat d'usuaris del programari lliure que es perden (i les hores i
saliva que es gasta) per decisions com aquesta.

Si Firefox 52 era un desastre en seguretat, també ho podrem dir de
Firefox 60 quan estiguem per la versió 70.
De manera que et dic jo: Si FF 52 funciona i FF 60 no, el desastre és de
l'últim.

Quan FF 52 era el normal, jo no podia preveure aquest disbarat com per a
bloquejar actualitzacions (hold), de manera que configuro els sistemes
per a què la gent se'ls pugui actualitzar (hauria de ser el normal), i
jo mateix aplico actualitzacions confiant en què és una bona idea.

Salut.


__________
I'm using this express-made address because personal addresses aren't
masked enough at this mail public archive. Public archive administrator
should fix this against automated addresses collectors.
El 17/5/19 a les 22:02, Alex Muntada ha escrit:
> Hola Narcis,
> 
>> S'acumulen les raons per les quals no s'hauria d'acceptar noves
>> versions d'aplicacions (com Firefox) als repositoris d'una
>> mateixa Debian.
> 
> Trobo que mantenir les versions antigues que tenen problemes de
> seguretat i no suporten els nous estàndards de web seria dolent
> per a molts usuaris de Debian.
> 
> És per aquest motiu que el firefox-esr és dels pocs paquets en
> què es fa una excepció i s'inclouen les noves versions, encara
> que siguin incompatibles cap enrere.
> 
>> És un desastre que Debian 9 hagi passat de Firefox 52 a Firefox
>> 60, bàsicament perquè s'ha ELIMINAT Firefox 52.
> 
> Entenc que és un desastre per al teu cas d'ús particular. Per la
> meva banda, jo estic molt content que s'hagi deixat enrera la
> tecnologia dels applets. Potser algunes administracions encara
> trigaran una mica en canviar els seus sistemes d'informació, però
> cada cop en queden menys.
> 
> Per un altre cop, si no vols que s'actualitzi un paquet tens
> l'opció de bloquejar-lo fent:
> 
>     $ sudo apt-mark hold ...
> 
> Ah! Recorda de repassar els paquets bloquejats abans de fer un
> upgrade de versió del sistema.
> 
> Salut!
> Alex
> 
> --
>   ⢀⣴⠾⠻⢶⣦⠀
>   ⣾⠁⢠⠒⠀⣿⡁  Alex Muntada <al...@debian.org>
>   ⢿⡄⠘⠷⠚⠋   Debian Developer - log.alexm.org
>   ⠈⠳⣄⠀⠀⠀⠀
> 

Respondre per correu electrònic a