El Tue, 15 May 2012 16:00:23 +0200, Ernest Sales escribió:

> On dl, 2012-05-14 at 14:12 +0000, Camaleón wrote: [...]
>> Bueno, eso lo pone bien claro en la página de descarga del programa.
>> Nos guste o no, la VM de Oracle es la que manda, y una aplicación
>> programada por y para ser ejecutada con la JRE de Oracle te puede dar
>> problemas si la ejecutas desde otra VM. Pero eso no es exclusivo del
>> programa PADRE,
> [...]
> 
> On dl, 2012-05-14 at 16:12 +0200, Luis Felipe Tabera wrote: [...]
>> La implementación openjdk, mal que me pese no es todo lo buena que
>> debería ser. Yo tengo instalada la de oracle porque hay programas
>> funciones que nunca he logrado que funciones con openjdk.
> [...]
> 
> Tal como se está poniendo Oracle [1] esta postura es suicida para el
> software libre. 

No, ojo, es una postura suicida para quien decide programar basándose en 
una versión concreta de una máquina virtual concreta de un proveedor 
concreto. 

Allá la AEAT si quiere que sus contribuyentes vuelvan al papel, pero yo  
dejaría constancia de ello y después, que hagan lo que quieran, que yo 
también lo haré, pero ya te digo que la administración no es el único 
caso que requiere de una VM concreta para que su aplicación "funcione".

> ¿Cuántas de las prestaciones más nuevas o sofisticadas, o sea que no
> estén [bien] soportadas en OpenJDK, puede necesitar un programa como el
> PADRE? 

Si el programa PADRE es de código abierto, alguien podrá hacer un listado 
exhaustivo.

> ¿No será que los programadores tienden a usar la última versión porque
> cuentan con que, como total es gratis, el usuario final dispondrá de
> ella? 

No creo que pidan la última versión (y ojo, que ya van por la v.7). Creo 
más bien que se trata de la vaguería que hay instaurada en este país 
(hacer lo mínimo para cobrar la nómina a fin de mes, es decir, la ley del 
mínimo esfuerzo) y de la manía que tienen las empresas (sobre todo las 
públicas) en hacer las cosas mal. Repito, la declaración debería de poder 
hacerse sin necesitad de instalar nada, directamente desde el navegador y 
con acceso a los servidores de la AEAT. Encima que pagamos, nos dan 
por... saco, nos dan por saco O:-)

> A mí lo que me fallaba era una ventana con un texto de aviso: me juego
> algo a que se podía haber hecho de forma que fuera compatible, pero
> como eso no es un requisito...

Hombre, pero por supuesto... de chorraditas y fallos tontunos de ese tipo 
están llenas las aplicaciones y las páginas web.

Saludos,

-- 
Camaleón


-- 
To UNSUBSCRIBE, email to debian-user-spanish-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive: http://lists.debian.org/jotrol$tg8$7...@dough.gmane.org

Responder a