Scott Henson wrote:
> On Sat, 2002-06-15 at 18:34, B. L. Jilek wrote:
>> I have a SuperMicro P6DBU motherboard with built in
>> SCSI.  All the drives are SCSI on the system.  I just
>> recently bought a 80G IDE drive to use for storage.
>> The problem is that after I installed the drive the
>> system booted up fine.  I have the bootup in the bios
>> to start with Floppy then SCSI drives.  It worked fine.
>> I was adding an append for the /dev/hda in lilo and ran
>>  lilo. When I did it gave me an warning that the drive
>> /dev/sda was not the first drive in the system.  After
>> rebooting the bios said it was booting from SCSI as
>> normal but I got the constant 01 01 01 01 thing.
>> I've tried various things like returning lilo to it's
>> original configuration and the bios was not modified
>> from when It used to boot fine.  I'm thinking it's a
>> lilo confusion problem.
>> The way I got around this was to install lilo on
>> /dev/hda with "other=/dev/sda" in it (the only thing in
>>  lilo.conf.hda).  And keeping lilo on /dev/sda to boot
>> the system.  It works fine like that.  As long as I set
>>  the bios to boot from IDE primary master instead of
>> from SCSI.  The problem with that setup is I can't boot
>>  from CDrom unless I change the bios back to booting
>> from SCSI.
>> I'm just wanting to know if there are any lilo tricks
>> to get it to see /dev/sda as the first drive.  Or if
>> anyone has experience with the SuperMicro P6DBU Board
>> that knows of this problem.
> Try grub, you wont have this type of problem.

I too had a problem like this with lilo (except I installed
a SCSI drive with an IDE drive already on the system and
then made a fresh install of debian on the SCSI hd). I then
installed grub and no longer have this problem :)

David P. James
Ottawa, Ontario

The bureaucratic mentality is the only constant in the universe.
-Dr. Leonard McCoy, Star Trek IV

To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]

Reply via email to