I'm trying to rebuild the nginx-extras package from Jessie and I'm running into 
an error when I run debuild. I want to add a module to Nginx. I've just been 
following this to rebuild the package: 

Here is what I've done:

1. Downloaded the source using apt.
     * apt-get source nginx-extras
2. Built the dependencies for the package
     * apt-get build-dep nginx-extras
3. Updated the debian/rules file to include my module
4. Added my module to the debian/modules directory
5. Ran debuild to compile the package.
     * debuild -us -uc

When I run the debuild command I get an error about no 
Test/nginx-1.6.2-5_deb8u2/auto directory existing. As the error suggests it 
doesn't exist, but I'm not sure how to fix it. Creating the directory just 
leads to another error. Would anybody be able to tell me why I'm getting this 
error and how to fix it. I do have devscripts installed on the machine.

jschaeffer@mutalisk:~/Build Test/nginx-1.6.2-5+deb8u2$ debuild -us -uc
make[1]: Entering directory '/home/jschaeffer/Build Test/nginx-1.6.2-5+deb8u2'
mkdir -p /home/jschaeffer/Build Test/nginx-1.6.2-5+deb8u2/debian/build-full
cp -Pa /home/jschaeffer/Build Test/nginx-1.6.2-5+deb8u2/auto 
/home/jschaeffer/Build Test/nginx-1.6.2-5+deb8u2/debian/build-full/
*cp: cannot stat ‘Test/nginx-1.6.2-5+deb8u2/auto’: No such file or directory*
cp: will not create hard link 
‘Test/nginx-1.6.2-5+deb8u2/debian/build-full/Build’ to directory 
debian/rules:141: recipe for target 'config.arch.full' failed
make[1]: *** [config.arch.full] Error 1
make[1]: Leaving directory '/home/jschaeffer/Build Test/nginx-1.6.2-5+deb8u2'
debian/rules:117: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
debuild: fatal error at line 1376:
dpkg-buildpackage -rfakeroot -D -us -uc failed

Reply via email to