On Mon, 21 Sep 2026 16:39:20 +0100 Joe <[email protected]> wrote: > Short version: my ISP does not (yet) provide IPv6 connectivity, and my > router was supplied by the ISP so already had IPv6 disabled. I was > having trouble with DNS failures due to bind9 not finding an IPv6 > route out of the network and giving up, even though the requested host > also had an IPv4 address.
I have the same situation: no IPv6 connectivity through my ISP. I solved the problem with bind by telling it to only use IPv4. root@issola:~# diff /etc/default/named* 6c6 < OPTIONS="-u bind -4" --- > OPTIONS="-u bind" root@issola:~# However, it will return IPv6 addresses, so you may still need to turn off IPv6 in other programs. > > I was advised that disabling IPv6 in the kernel was the final fix,…. I have not found that necessary. -- Does anybody read signatures any more? https://charlescurley.com https://charlescurley.com/blog/

