On 2026-09-23 12:00:10 +0200, Marco Moock wrote:
> Am 23.09.26 um 11:50 schrieb Vincent Lefevre:
> > On 2026-09-22 15:33:05 +0200, Marco Moock wrote:
> > > Am 22.09.26 um 05:30 schrieb Max Nikulin:
> > > > The issue is that nscd caches for an hour results with some IPv6
> > > > addresses and no IPv4 ones due to SERVFAIL in response to the A query.
> > > > As a result various tools can not connect the host due to lack of global
> > > > IPv6 routing.
> > > 
> > > Not an IPv6 issue and not an nscd issue.
> > > If nscd caches the positive (e.g. answer with A/AAAA record) or negative
> > > (server replies that the requested record does not exist) answer, it is
> > > operation correctly. The failing DNS servers need to be handled at
> > > libnss_dns.
> > 
> > Or perhaps nscd just misuses libnss_dns. Without documentation of
> > how nscd uses this library exactly, who knows?
> 
> The libraries are queried in order listed in nsswitch.conf. This can be
> tuned (continue after a successful query, retry options etc.) with some
> settings, see the nsswitch.conf manpage.

I repeat: "hosts: files dns". But given the fact that these are
arbitrary remote hosts, "files" will not give an answer. So this
yields "dns". But I don't know how this is handled.

> nscd is just a cache between the requesting application and the actual
> resolver libraries.

You're repeating that, but tests show that it is not true. The IPv4
address is cached, but nscd does not always give it in its response
with AF_UNSPEC.

-- 
Vincent Lefèvre <[email protected]> - Web: <https://www.vinc17.net/>
100% accessible validated (X)HTML - Blog: <https://www.vinc17.net/blog/>
Work: CR INRIA - computer arithmetic / Pascaline project (LIP, ENS-Lyon)

Reply via email to