Hello Alexander,

thank you for your answer.
the ffb/metadata.php file does not exists anymore. It is old module which is 
was removed on shop update.
The old module had no invalid entries and worked pretty well with OXID EE 4.6.3
The metadata of old module contains classes which can't be removed:
'oxutilsfile'                         => 'ffb/core/ffb_oxutilsfile',
'oxutilspic'                          => 'ffb/core/ffb_oxutilspic',
'oxuserbasket'                =>  'ffb/core/ffb_oxuserbasket'

I don't know, maybe is there any another database table except oxconfig which 
contains module entries.
I mean after removing of aModules from oxconfig, where can those broken entries 
be stored?

Kind regards,
Alexander Scheider

Von: dev-general-boun...@lists.oxidforge.org 
[mailto:dev-general-boun...@lists.oxidforge.org] Im Auftrag von Alex Schwarz
Gesendet: Mittwoch, 30. März 2016 13:09
An: dev-general@lists.oxidforge.org
Betreff: Re: [oxid-dev-general] Can't remove old module entries

Hi Alexander,

did you check the ffb/metadata.php for invalid entries? There could be an 
old/invalid entry, maybe you reference a file there that does no longer exists?

If you are using PHPStorm with the OXID Plugin enabled, you will have syntax 
support for metadata.php!

Best regards

Alexander Schwarz
Senior Web Developer


active value GmbH
Benzenbergstraße 39-47
40219 Düsseldorf

Telefon: +49 (0)211-749 505 15
Telefax: +49 (0)211 749 505 99

E-Mail:   alex.schw...@active-value.de<mailto:alex.schw...@active-value.de>
Internet: www.active-value.de<http://www.active-value.de>

HRB 55441, Amtsgericht Düsseldorf
Geschäftsführer: Antonius Klees, Alexander Pisculla

P Please consider the environment before printing this email

Alexander Scheider<mailto:alexander.schei...@4fb.de>
30. März 2016 um 13:03
Hi folks,

I'm using OXID EE 5.2.7 and  have a problem with old module entries which can't 
be deleted in OXID backend or database.
Every time by clicking on Extensions -> Modules i get following list:


After click on yes i see the list with all installed modules, but if i enter 
the modules next time,  the dialog appears again.
I have got already tried to reset the modules from oxconfig with
 WHERE `OXVARNAME` = 'aModules'

Or to remove all informations with:
delete from oxconfig where oxvarname in (

I also tried to export config with 
https://github.com/druteika/oxid_modules_config module.
In every extend of all modules i have those old entries:
"oxutilsfile": "ffb\/core\/ffb_oxutilsfile",
 "oxutilspic": "ffb\/core\/ffb_oxutilspic",
 "oxuserbasket": "ffb\/core\/ffb_oxuserbasket"

Modification of json-file and reimport of configuration didn't helped. After 
import of the configuration, open Extensions  -> Modules and export of config 
again, the entries are added again to the extend array.

OXID-Console command had also no luck: php oxid fix:states -all

Does anyone have any advice how to fix this problem.

Kind regards,
Alexander Scheider

dev-general mailing list
dev-general mailing list

Reply via email to