Hi Ariel,

yes, b) is a bug. You can submit an issue to me. It seems that i forgot this when insert the hostname.

For a) i am not sure. I would say no but it can be improved. I thought about a further option to allow different configurations. Not available at the moment. You can submit an RFE.

The hostname is nice if you share your home directory for different systems as in our local env in Hamburg. The same homed dir for Linux, Solaris etc.


Ariel Constenla-Haile wrote:
Hello *,

this is the scenario: I have "installed" a DEV300_m36 version (build
with dbgutil, and some modules with symbols enabled), so I need an SDK
of its own.

While trying to set this SDK env. parallel to the "normal" one, I find
the following:

- I "installed" OOo under /home/ariel/OOo_DEBUG/
- the sdk is so in /home/ariel/OOo_DEBUG/openoffice.org/basis3.1/sdk

* when I run
/home/ariel/OOo_DEBUG/openoffice.org/basis3.1/sdk/setsdkenv_unix it will
first detect if there is already a standard sdk env. under
/home/ariel/openoffice.org3.0_sdk; this can be solved with --force-configure

* problem is that after setting the output directory in
/home/ariel/OOo_DEBUG (and not the default /home/ariel)

-  a directory is created under
/home/ariel/OOo_DEBUG/openoffice.org3.0_sdk that contains in linux/lib/
symlinks to the URE libs; this is OK

- a directory is created under /home/ariel/openoffice.org3.0_sdk that
contains scripts in
this seems to be wrong

(a) shouldn't these scripts be created in the specified output directory
(/home/ariel/OOo_DEBUG)  instead of the default (/home/ariel)?

in configure.pl, prepareScriptFile() writes the files to
OO_SDK_CONFIG_HOME, but it should have been set first to
OO_SDK_OUTPUT_DIR (if this last was set by the user)

(b) this message printed by the script is wrong:

 * ... your SDK environment has been prepared.
 * For each time you want to use this configured SDK environment, you
 * have to run the "setsdkenv_unix" script file!
 * Alternatively can you source one of the scripts
 *   "/home/ariel/openoffice.org3.0_sdk/setsdkenv_unix.sh"
 *   "/home/ariel/openoffice.org3.0_sdk/setsdkenv_unix.csh"
 * to get an environment without starting a new shell.

it misses the host name:

 *   "/home/ariel/openoffice.org3.0_sdk/localhost/setsdkenv_unix.sh"
 *   "/home/ariel/openoffice.org3.0_sdk/localhost/setsdkenv_unix.csh"

so configure.pl should be

print " *
print " *

instead of

print " *   \"$main::OO_SDK_CONFIG_HOME/setsdkenv_unix.sh\"\n";
print " *   \"$main::OO_SDK_CONFIG_HOME/setsdkenv_unix.csh\"\n";

Finally, a nice-to-have for the NB plug-in would be the option to switch
between OOo installation/SDK envs. *per project* (currently it's only
possible a global configuration).


To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to