[ 
https://issues.apache.org/jira/browse/DELTASPIKE-1354?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

THEODOROS CHAIKALIS updated DELTASPIKE-1354:
--------------------------------------------
    Summary: CDI producer does not work properly after application restart on 
weblogic 12c  (was: CDI producer does not work correctly after application 
restart on weblogic 12c)

> CDI producer does not work properly after application restart on weblogic 12c
> -----------------------------------------------------------------------------
>
>                 Key: DELTASPIKE-1354
>                 URL: https://issues.apache.org/jira/browse/DELTASPIKE-1354
>             Project: DeltaSpike
>          Issue Type: Bug
>          Components: CdiControl, Data-Module
>    Affects Versions: 1.8.0
>         Environment: Windows 10, Weblogic 12.2.1.3, 
>            Reporter: THEODOROS CHAIKALIS
>            Priority: Major
>              Labels: cdi, entitymanager, producer, repository
>         Attachments: EnterpriseWebApp.zip
>
>
> I have an application using Deltaspike 1.8.0 that runs on Weblogic 12.2.1.3.
> Attached you will find a mini application that demonstrates the problem, 
> please use it.
> The scenario to reproduce the problem is as follows:
> 1. Deploy the application on Weblogic.
> 2. Run a REST service that uses a Deltaspike repository: 
> [http://localhost:7001/ssp.sandbox/persons/all] 
> or
>   [http://localhost:7001/ssp.sandbox/persons/byId/1]
> 3. Observe that the request runs smoothly. If you want Data run the TestA 
> class
> 4. from the weblogic console, stop the application
> 5. Start the application
> 6. run again a rest from step 2. The following will happen:
>  
> [https://gist.github.com/teohaik/933d4bc47d38c4441ca9a7409bc90eee]
>  
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to