[ https://issues.apache.org/jira/browse/HIVE-5402?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13786607#comment-13786607 ]
Sushanth Sowmyan commented on HIVE-5402: ---------------------------------------- > Rename isRunFromMetaStore to serverMode Hmm.. One one hand, that makes sense, since client-side running also launches a metastore, just that it is a local metastore. serverMode makes that clear. On the other hand, there's nothing that stops this from being run from that local metastore. The distinction here is whether it is being called from Hive or HiveMetaStore, and as such, isRunFromMetastore is more accurate here. That said, I'm not going to be a stickler about this, so am willing to change it if you still think it should change. > Do Hive.get(getConf()) instead of Hive.get(new HiveConf()) because its > expensive object to initialize and we don't multiple copies of configuration > to be active in a process. Hahaha, I expected this, and was specifically thinking of you when I wrote that, and hunted around in advance! :D Unfortunately, Hive.get does not accept a Configuration, which is what getConf() returns. It needs a HiveConf. If you prefer, I can do a instanceof check to see if the Configuration I have is actually a HiveConf, and if so, cast and give it directly. > StorageBasedAuthorizationProvider is not correctly able to determine that it > is running from client-side > -------------------------------------------------------------------------------------------------------- > > Key: HIVE-5402 > URL: https://issues.apache.org/jira/browse/HIVE-5402 > Project: Hive > Issue Type: Bug > Components: Authorization > Reporter: Sushanth Sowmyan > Assignee: Sushanth Sowmyan > Attachments: HIVE-5402.2.patch, HIVE-5402.patch > > > HIVE-5048 tried to change the StorageBasedAuthorizationProvider (SBAP) so > that it could be run from the client side as well. > However, there is a bug that causes SBAP to incorrectly conclude that it's > running from the metastore-side when it's actually running from the > client-side that causes it to throw a IllegalStateException claiming the > warehouse variable isn't set. -- This message was sent by Atlassian JIRA (v6.1#6144)