----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/14523/#review27105 -----------------------------------------------------------
service/src/java/org/apache/hive/service/cli/CLIService.java <https://reviews.apache.org/r/14523/#comment52763> This can lead to a misleading error message. I think it is better to have two try-catch blocks. service/src/test/org/apache/hive/service/cli/TestScratchDir.java <https://reviews.apache.org/r/14523/#comment52765> Thanks for adding a test case! Can you change "/tmp" to System.getProperty("test.tmp.dir"); ? Even better would be to also rename "foobar" to "TestScratchDirs_foobar" It looks straightforward to add check for other two configured dirs. Can you include them as well ? - Thejas Nair On Oct. 9, 2013, 6:34 a.m., Prasad Mujumdar wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/14523/ > ----------------------------------------------------------- > > (Updated Oct. 9, 2013, 6:34 a.m.) > > > Review request for hive. > > > Bugs: HIVE-5486 > https://issues.apache.org/jira/browse/HIVE-5486 > > > Repository: hive-git > > > Description > ------- > > With impersonation enabled, the same base directory is used by all > sessions/queries. For a new deployment, this directory gets created on first > invocation by the user running that session. This would cause directory > permission conflict for other users. > The patch is creating base scratch dirs at startup if it doesn't exist. > > > Diffs > ----- > > common/src/java/org/apache/hadoop/hive/conf/HiveConf.java d0895e1 > service/src/java/org/apache/hive/service/cli/CLIService.java 1a7f338 > > service/src/java/org/apache/hive/service/cli/session/HiveSessionImplwithUGI.java > ae7bb6b > > service/src/test/org/apache/hive/service/cli/TestEmbeddedThriftBinaryCLIService.java > da325da > service/src/test/org/apache/hive/service/cli/TestScratchDir.java > PRE-CREATION > > Diff: https://reviews.apache.org/r/14523/diff/ > > > Testing > ------- > > Added new test > > > Thanks, > > Prasad Mujumdar > >