Hi there,

I just spent some time enabling the animal sniffer plugin in Jackrabbit branches (see https://issues.apache.org/jira/browse/JCR-4025).


While trying to do so for 2.4, I noticed that although the pom.xml claims that it is on JDK 5, there's code in there that relies on JDK 6 libraries, introduced over three years ago with <https://fisheye6.atlassian.com/changelog/jackrabbit?cs=1516397>.

Proposal:

- change the pom.xml to required JDK 6 (and turn on JDK sniffing)

But also:

- officially end-of-life Jackrabbit 2.4 (for which the release of 2.4.6 would be the last one)

So let's vote:

[ ] declare end-of-life for Jackrabbit 2.4 after the upcoming 2.4.6 release
 [ ]  continue to maintain Jackrabbit 2.4

I'll wait 72 hours for feedback.

Best regards, Julian

Reply via email to