[ 
https://issues.apache.org/jira/browse/LUCENE-6975?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15105083#comment-15105083
 ] 

Robert Muir commented on LUCENE-6975:
-------------------------------------

To me its the word "Dimensional" in these names that is the scary one.

But we need to break here, we can't name things e.g. FloatField or there is a 
big risk of users mixing the two things. We've also got FloatDocValuesField 
that we don't want to cause confusion with. And somehow it needs to be clear 
that e.g. you need DimensionalQuery to use it, TermQuery won't work. To me 
thats a difference vs a regular Field.

One idea is the part "Field" could be something different. For example instead 
of FloatDocValuesField we could have "FloatColumn", you add that to your 
document, and then we have ColumnRangeQuery that goes with it, instead of 
DocValuesRangeQuery. In that case, i feel like the different term really helps 
you think about what is going on vs Field.

But what to use for Dim values? FloatValue wouldn't be totally horrible, but I 
feel like "value" is overloaded too much, is there a better term we can use?


> Add dimensional "equals" query to match docs containing precisely a given 
> value
> -------------------------------------------------------------------------------
>
>                 Key: LUCENE-6975
>                 URL: https://issues.apache.org/jira/browse/LUCENE-6975
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: Trunk, 6.0
>
>
> Today, you can make a dimensional range query using e.g. 
> {{DimensionalRangeQuery.new1DIntRange}}, etc., plus a direct ctor for 
> "expert" (2D, 3D, etc.) usages, but matching a single value is awkward and 
> users ask about it from time to time.
> We could maybe rename {{DimensionalRangeQuery}} to {{DimensionalQuery}} and 
> add new "factories" like {{newIntEqualsQuery}} or something.
> Or, we could make new classes, {{DimensionalIntEqualsQuery}} etc., and you 
> get to use ordinary constructors?
> Or something else?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to