[
https://issues.apache.org/jira/browse/LUCENE-6975?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15105121#comment-15105121
]
Robert Muir commented on LUCENE-6975:
-------------------------------------
i do like your idea, those are just some devil's advocate ideas. At least point
seems way more intuitive than what we have in trunk and i dont have anything
better. It definitely seems better than dimensional and doesn't make me think
about mad scientists or time travel.
Just the general idea is something to think about, simple names like fields,
columns, and points could help people use the right datastructure for the job.
> Add dimensional "equals" query to match docs containing precisely a given
> value
> -------------------------------------------------------------------------------
>
> Key: LUCENE-6975
> URL: https://issues.apache.org/jira/browse/LUCENE-6975
> Project: Lucene - Core
> Issue Type: Improvement
> Reporter: Michael McCandless
> Assignee: Michael McCandless
> Fix For: Trunk, 6.0
>
>
> Today, you can make a dimensional range query using e.g.
> {{DimensionalRangeQuery.new1DIntRange}}, etc., plus a direct ctor for
> "expert" (2D, 3D, etc.) usages, but matching a single value is awkward and
> users ask about it from time to time.
> We could maybe rename {{DimensionalRangeQuery}} to {{DimensionalQuery}} and
> add new "factories" like {{newIntEqualsQuery}} or something.
> Or, we could make new classes, {{DimensionalIntEqualsQuery}} etc., and you
> get to use ordinary constructors?
> Or something else?
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]