[
https://issues.apache.org/jira/browse/LUCENE-6975?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15105112#comment-15105112
]
Robert Muir commented on LUCENE-6975:
-------------------------------------
Well I do think we should avoid "Value" unless it adds some additional meaning.
Thats one problem with doc values, its basically a name that says nothing!
Do you mean something like IntPointValue etc? Why not just IntPoint? Point
isn't bad at all, since it does represent what is happening.
On the other hand, if i just have 'int age' in my document and i want to do
range queries on it, its hard to know if that would be the intuitive thing to
look into, you'd have to think "oh, i need to treat it like a 1-dimensional
point".
> Add dimensional "equals" query to match docs containing precisely a given
> value
> -------------------------------------------------------------------------------
>
> Key: LUCENE-6975
> URL: https://issues.apache.org/jira/browse/LUCENE-6975
> Project: Lucene - Core
> Issue Type: Improvement
> Reporter: Michael McCandless
> Assignee: Michael McCandless
> Fix For: Trunk, 6.0
>
>
> Today, you can make a dimensional range query using e.g.
> {{DimensionalRangeQuery.new1DIntRange}}, etc., plus a direct ctor for
> "expert" (2D, 3D, etc.) usages, but matching a single value is awkward and
> users ask about it from time to time.
> We could maybe rename {{DimensionalRangeQuery}} to {{DimensionalQuery}} and
> add new "factories" like {{newIntEqualsQuery}} or something.
> Or, we could make new classes, {{DimensionalIntEqualsQuery}} etc., and you
> get to use ordinary constructors?
> Or something else?
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]