[ 
https://issues.apache.org/jira/browse/LUCENE-7094?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15209769#comment-15209769
 ] 

David Smiley commented on LUCENE-7094:
--------------------------------------

bq. It's necessary to cut over from UninvertingReader - which still works on 
5.x segments - to DocValues. If you just set DocValues.NUMERIC on a DoubleField 
the Double.longValue is what's stored as the DocValue (aka the truncated value).

I don't understand that; you description sounds related to ComboField not to 
UninvertingReader, but I'm not sure.  Tomorrow I'll try with a debugger to see 
why it doesn't work (presumably a test fails).  

Note that adding this field suffix will break back-compat with a 5.x index for 
someone using this strategy since their data won't be in a {{_dv}} suffixed 
field.  If we need to keep the suffix, we should add a note to the CHANGES.txt 
that this is so.

bq. (RE ComboField) It's unnecessary - especially once legacy numerics are 
removed in 7.0 since Point types lock down the FieldType. There is no need to 
Circumvent Field limitations, anyway.

Even without PointValues, it's definitely not strictly _necessary_.  It was a 
convenient hack enabling the code to return exactly 5 field values instead of 
sometimes 9.  Now with PointValues we might need 9.  FYI note that 
DoubleDocValuesField doesn't allow setting the stored value, but ComboField can 
do stored value + DV in one shot.

> spatial-extras BBoxStrategy and (confusingly!) PointVectorStrategy use legacy 
> numeric encoding
> ----------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-7094
>                 URL: https://issues.apache.org/jira/browse/LUCENE-7094
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Robert Muir
>            Assignee: Nicholas Knize
>         Attachments: LUCENE-7094.patch
>
>
> We need to deprecate these since they work on the old encoding and provide 
> points based alternatives.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to