Hi everyone, I have subscribed to the dev list today.

I have been working through the section "Installing the ARM Toolchain For Linux" and have completed:

apt-get install gcc-arm-none-eabi

...

Setting up gcc-arm-none-eabi (15:5.4.1+svn241155-1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...

successfully.

Next task: "Installing the OpenOCD Debugger"

I have installed: https://github.com/runtimeco/openocd-binaries/raw/master/openocd-bin-0.10.0-Linux.tgz

which (in Debian 9.4) has problems with dependencies.

I tried to install openocd_0.10.0-4_amd64.deb but this also has problems with dependencies:

The following packages have unmet dependencies:
 openocd : Depends: libjaylink0 but it is not installable
           Depends: libjim0.77 (>= 0.73) but it is not installable
E: Unable to correct problems, you have held broken packages.


root@kgdebian:~# apt-get install /root/Downloads/libjaylink0_0.1.0-1_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libjaylink0' instead of '/root/Downloads/libjaylink0_0.1.0-1_amd64.deb'
The following NEW packages will be installed:
  libjaylink0
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/17.1 kB of archives.
After this operation, 62.5 kB of additional disk space will be used.
Get:1 /root/Downloads/libjaylink0_0.1.0-1_amd64.deb libjaylink0 amd64 0.1.0-1 [17.1 kB]
Selecting previously unselected package libjaylink0.
(Reading database ... 304002 files and directories currently installed.)
Preparing to unpack .../libjaylink0_0.1.0-1_amd64.deb ...
Unpacking libjaylink0 (0.1.0-1) ...
Setting up libjaylink0 (0.1.0-1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
N: Download is performed unsandboxed as root as file '/root/Downloads/libjaylink0_0.1.0-1_amd64.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

I was able to resolve:

apt-get install libftdi1-2
apt-get install libhidapi-hidraw0

apt-get install libusb-0.1-4

but I am unable to resolve libjim0.77

Perhaps I should return to: https://github.com/runtimeco/openocd-binaries/raw/master/openocd-bin-0.10.0-Linux.tgz

Has anyone installed this tar on Debian? What list of dependencies did you use (with version numbers)?

Your help would be much appreciated.

Regards,

Kevin.


Reply via email to