I hope I have fixed this problem:

looked at: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887425 NO FIX?

I deleted newt.gpg and trusted.gpg then:

root@kgdebian:~# wget https://raw.githubusercontent.com/runtimeco/binary-releases/master/mynewt-newt-tools_1.3.0/newt_1.3.0-1_amd64.deb --2018-03-14 16:47:12-- https://raw.githubusercontent.com/runtimeco/binary-releases/master/mynewt-newt-tools_1.3.0/newt_1.3.0-1_amd64.deb Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.0.133, 151.101.64.133, 151.101.128.133, ... Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.0.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1470322 (1.4M) [application/octet-stream]
Saving to: ‘newt_1.3.0-1_amd64.deb’

newt_1.3.0-1_amd64. 100%[===================>]   1.40M 6.04MB/s    in 0.2s

2018-03-14 16:47:13 (6.04 MB/s) - ‘newt_1.3.0-1_amd64.deb’ saved [1470322/1470322]

root@kgdebian:~# dpkg -i newt_1.3.0-1_amd64.deb
Selecting previously unselected package newt.
(Reading database ... 309022 files and directories currently installed.)
Preparing to unpack newt_1.3.0-1_amd64.deb ...
Unpacking newt (1.3.0-1) ...
Setting up newt (1.3.0-1) ...
root@kgdebian:~# which newt
/usr/bin/newt
root@kgdebian:~# newt version
Apache Newt version: 1.3.0
root@kgdebian:~# apt-key update
Warning: 'apt-key update' is deprecated and should not be used anymore!
Note: In your distribution this command is a no-op and can therefore be removed safely. W: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file has an unsupported filetype.
root@kgdebian:~# apt update
Get:1 http://ftp.nz.debian.org/debian testing InRelease [142 kB]
Get:2 http://ftp.nz.debian.org/debian testing/main amd64 Packages.diff/Index [27.9 kB] Get:3 http://ftp.nz.debian.org/debian testing/main amd64 Packages 2018-03-13-2023.44.pdiff [1,018 B] Get:3 http://ftp.nz.debian.org/debian testing/main amd64 Packages 2018-03-13-2023.44.pdiff [1,018 B]
Fetched 171 kB in 4s (45.3 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
822 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: http://ftp.nz.debian.org/debian/dists/testing/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file has an unsupported filetype.
root@kgdebian:~# apt update
Hit:1 http://ftp.nz.debian.org/debian testing InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
822 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@kgdebian:~#

Now I hope...

Kevin.

Reply via email to