Hello Markus,

I have successfully upgraded from Debian Stretch to Testing (Busty) and installed openocd:


root@kgdebian:~# which openocd
/usr/bin/openocd
root@kgdebian:~# openocd -v
Open On-Chip Debugger 0.10.0
Licensed under GNU GPL v2
For bug reports, read
    http://openocd.org/doc/doxygen/bugs.html

I then moved onto installing newt:

root@kgdebian:~# wget -qO - https://raw.githubusercontent.com/runtimeco/debian-mynewt/master/mynewt.gpg.key | sudo apt-key add -
OK
W: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file has an unsupported filetype.
root@kgdebian:~# sudo tee /etc/apt/sources.list.d/mynewt.list <<EOF
> deb [arch=amd64] https://raw.githubusercontent.com/runtimeco/debian-mynewt/master latest main
> EOF
deb [arch=amd64] https://raw.githubusercontent.com/runtimeco/debian-mynewt/master latest main
root@kgdebian:~# apt-get update
Get:1 https://raw.githubusercontent.com/runtimeco/debian-mynewt/master latest InRelease [1,762 B]
Hit:2 http://ftp.nz.debian.org/debian testing InRelease
Err:1 https://raw.githubusercontent.com/runtimeco/debian-mynewt/master latest InRelease   The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4E9A819250B4B104
Reading package lists... Done
W: https://raw.githubusercontent.com/runtimeco/debian-mynewt/master/dists/latest/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file has an unsupported filetype. W: GPG error: https://raw.githubusercontent.com/runtimeco/debian-mynewt/master latest InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4E9A819250B4B104 E: The repository 'https://raw.githubusercontent.com/runtimeco/debian-mynewt/master latest InRelease' is not signed. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. W: http://ftp.nz.debian.org/debian/dists/testing/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file has an unsupported filetype.

Which has problems with: " The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file has an unsupported filetype."

root@kgdebian:~# apt-key list
/etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg
----------------------------------------------------------
pub   rsa4096 2014-11-21 [SC] [expires: 2022-11-19]
      126C 0D24 BD8A 2942 CC7D  F8AC 7638 D044 2B90 D010
uid           [ unknown] Debian Archive Automatic Signing Key (8/jessie) <ftpmas...@debian.org>

/etc/apt/trusted.gpg.d/debian-archive-jessie-security-automatic.gpg
-------------------------------------------------------------------
pub   rsa4096 2014-11-21 [SC] [expires: 2022-11-19]
      D211 6914 1CEC D440 F2EB  8DDA 9D6D 8F6B C857 C906
uid           [ unknown] Debian Security Archive Automatic Signing Key (8/jessie) <ftpmas...@debian.org>

/etc/apt/trusted.gpg.d/debian-archive-jessie-stable.gpg
-------------------------------------------------------
pub   rsa4096 2013-08-17 [SC] [expires: 2021-08-15]
      75DD C3C4 A499 F1A1 8CB5  F3C8 CBF8 D6FD 518E 17E1
uid           [ unknown] Jessie Stable Release Key <debian-rele...@lists.debian.org>

/etc/apt/trusted.gpg.d/debian-archive-stretch-automatic.gpg
-----------------------------------------------------------
pub   rsa4096 2017-05-22 [SC] [expires: 2025-05-20]
      E1CF 20DD FFE4 B89E 8026  58F1 E0B1 1894 F66A EC98
uid           [ unknown] Debian Archive Automatic Signing Key (9/stretch) <ftpmas...@debian.org>
sub   rsa4096 2017-05-22 [S] [expires: 2025-05-20]

/etc/apt/trusted.gpg.d/debian-archive-stretch-security-automatic.gpg
--------------------------------------------------------------------
pub   rsa4096 2017-05-22 [SC] [expires: 2025-05-20]
      6ED6 F5CB 5FA6 FB2F 460A  E88E EDA0 D238 8AE2 2BA9
uid           [ unknown] Debian Security Archive Automatic Signing Key (9/stretch) <ftpmas...@debian.org>
sub   rsa4096 2017-05-22 [S] [expires: 2025-05-20]

/etc/apt/trusted.gpg.d/debian-archive-stretch-stable.gpg
--------------------------------------------------------
pub   rsa4096 2017-05-20 [SC] [expires: 2025-05-18]
      067E 3C45 6BAE 240A CEE8  8F6F EF0F 382A 1A7B 6500
uid           [ unknown] Debian Stable Release Key (9/stretch) <debian-rele...@lists.debian.org>

/etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg
----------------------------------------------------------
pub   rsa4096 2012-04-27 [SC] [expires: 2020-04-25]
      A1BD 8E9D 78F7 FE5C 3E65  D8AF 8B48 AD62 4692 5553
uid           [ unknown] Debian Archive Automatic Signing Key (7.0/wheezy) <ftpmas...@debian.org>

/etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg
-------------------------------------------------------
pub   rsa4096 2012-05-08 [SC] [expires: 2019-05-07]
      ED6D 6527 1AAC F0FF 15D1  2303 6FB2 A1C2 65FF B764
uid           [ unknown] Wheezy Stable Release Key <debian-rele...@lists.debian.org>

W: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file has an unsupported filetype.

I can't install newt. My os can't find it. Have you seen this problem before?

Regards,

Kevin.


On 13/03/2018 2:43 AM, markus wrote:
Hey Kevin,

I'm running Debian Testing and use the stock openocd that comes with it. I use 
the newt tools from the runtimco apt repo. Everything seems to work well and I 
don't remember there being any issues with dependencies.

HTH,
Markus

On Tue, 13 Mar 2018 02:21:20 +0000
Kevin & Pauline Gordon <kgplg...@gmail.com> wrote:

Hi everyone, I have subscribed to the dev list today.

I have been working through the section "Installing the ARM Toolchain
For Linux" and have completed:

apt-get install gcc-arm-none-eabi

...

Setting up gcc-arm-none-eabi (15:5.4.1+svn241155-1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...

successfully.

Next task: "Installing the OpenOCD Debugger"

I have installed:
https://github.com/runtimeco/openocd-binaries/raw/master/openocd-bin-0.10.0-Linux.tgz

which (in Debian 9.4) has problems with dependencies.

I tried to install openocd_0.10.0-4_amd64.deb but this also has
problems with dependencies:

The following packages have unmet dependencies:
   openocd : Depends: libjaylink0 but it is not installable
             Depends: libjim0.77 (>= 0.73) but it is not installable
E: Unable to correct problems, you have held broken packages.


root@kgdebian:~# apt-get install
/root/Downloads/libjaylink0_0.1.0-1_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libjaylink0' instead of
'/root/Downloads/libjaylink0_0.1.0-1_amd64.deb'
The following NEW packages will be installed:
    libjaylink0
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/17.1 kB of archives.
After this operation, 62.5 kB of additional disk space will be used.
Get:1 /root/Downloads/libjaylink0_0.1.0-1_amd64.deb libjaylink0 amd64
0.1.0-1 [17.1 kB]
Selecting previously unselected package libjaylink0.
(Reading database ... 304002 files and directories currently
installed.) Preparing to unpack .../libjaylink0_0.1.0-1_amd64.deb ...
Unpacking libjaylink0 (0.1.0-1) ...
Setting up libjaylink0 (0.1.0-1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
N: Download is performed unsandboxed as root as file
'/root/Downloads/libjaylink0_0.1.0-1_amd64.deb' couldn't be accessed
by user '_apt'. - pkgAcquire::Run (13: Permission denied)

I was able to resolve:

apt-get install libftdi1-2
apt-get install libhidapi-hidraw0

apt-get install libusb-0.1-4

but I am unable to resolve libjim0.77

Perhaps I should return to:
https://github.com/runtimeco/openocd-binaries/raw/master/openocd-bin-0.10.0-Linux.tgz

Has anyone installed this tar on Debian? What list of dependencies
did you use (with version numbers)?

Your help would be much appreciated.

Regards,

Kevin.



Reply via email to