Tested using OpenOffice 4.1.5 & macOS 10.13.3 High Sierra

Saved an existing .odt & a .doc file as "Microsoft Word 2003 XML (.xml)"
Both files saved and reopened.


On 2018-02-13, 4:56 PM Andrea Pescetti wrote concerning "Bug on macOS X and Microsoft Word 2003 XML format":
A bug has been reported on the Italian mailing list but I'd like to get verification by a Mac user.

To reproduce:

1. Be on High Sierra (but it would be useful to check with other versions too; the reporter says everything worked correctly, with OpenOffice 4.1.5, before upgrading to High Sierra). OpenOffice 4.1.5.

2. Create a new text document, write "Test", save as "Microsoft Word 2003 XML (.xml)" - a rather rare format, but we officially support it.

3. One should be able to save the document and reopen it correctly. The reporter says he gets "Write error" on High Sierra with 4.1.5 (and the file is not saved), while his previous macOS version worked fine with 4.1.5.

Note: .odt and .doc work well; only that specific format is problematic. Also note: I couldn't reproduce the issue on Linux.

The bug would not be particularly important in itself, but the many build attempts with XML libraries on macOS make this worth checking.




Larry I. Gusaas
Moose Jaw, Saskatchewan Canada
Website: http://larry-gusaas.com

"An artist is never ahead of his time but most people are far behind theirs." - 
Edgard Varese

Reply via email to