See https://github.com/zerebubuth/openstreetmap-cgimap/issues/189

Your app should be working again right now as Tom has reverted back to
the Rails implemetation, still you should likely be using OAuth to start
with.

Simon

Am 30.05.2019 um 21:33 schrieb Colin Smale:
>
> A (private) program I use which accesses the OSM API has stopped
> working since the last time I used it, a couple of weeks ago.
> Read-only calls to the API, including a (proven correct)
> Authentication header are now failing with 401 Unauthorized, with the
> returned body indicating a problem with the username/password. The
> same call without the Authorization header succeeds. I swear nothing
> has changed on my side; double-checking the auth header with Fiddler
> shows the username/password I expect, and I can still logout/login
> using these values (which I haven't changed).
>
> Is there anything going on, or has anything changed on the API, that
> may be causing this?
>
> Sample URL: GET onĀ https://api.openstreetmap.org/api/0.6/relation/8465619
>
> I know I can just remove the authentication - it was added for "future
> use" anyway - but why has it suddenly broken?
>
> Thanks,
>
> Colin
>
>
> _______________________________________________
> dev mailing list
> dev@openstreetmap.org
> https://lists.openstreetmap.org/listinfo/dev

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
dev mailing list
dev@openstreetmap.org
https://lists.openstreetmap.org/listinfo/dev

Reply via email to