-----Original Message-----
From: Adam Williamson <adamw...@fedoraproject.org>
To: hlhow...@pacbell.net, Development discussions related to Fedora <de
Subject: Re: failure of f24 to f25 upgrade
Date: Thu, 01 Dec 2016 11:41:23 -0800

On Thu, 2016-12-01 at 11:32 -0800, Howard Howell wrote:
> Hi, everyone,
>       I have been trying to upgrade my system from f24 to f25 using
> the cli in the terminal.
>   814  dnf system-upgrade download --releasever=25
>   815  dnf system-upgrade download --releasever=25 --allowerasing
>   816  dnf system-upgrade download --releasever=25 --allowerasing --
> nogpgcheck
>   all run from superuser.
>   error: 
> Running transaction check
> Transaction check succeeded.
> Running transaction test
> The downloaded packages were saved in cache until the next successful
> transaction.
> You can remove cached packages by executing 'dnf clean packages'.
> Error: Transaction check error:
>   file /usr/bin from install of google-earth-stable-
> 0.x86_64 
> conflicts with file from package filesystem-3.2-37.fc24.x86_64
>   # dnf --system-upgrade reboot
> will not run due to same error.
> I have obtained the google key and installed it using pgp install,
> but
> no change.  Here are some of the other things I have tried:
>     dnf distrosync
>     dnf help
>     dnf upgrade google_Earth
>     dnf upgrade google-earth
>     dnf system-upgrade --nogpgcheck reboot
>     dnf erase googleearth
> The erase google earth I have tried also with the full name
>     dnf erase google-earth-stable-
>     No match for argument: google-earth-stable-
>     Error: No packages marked for removal.
> Given that I cannot erase the offending package, I tried:
>     dnf system-upgrade reboot --allowerasing
>     Error: system is not ready for upgrade
> Yet again with nogpgcheck
>       dnf system-upgrade reboot --nogpgcheck
>       Error: system is not ready for upgrade
> A straight reboot will bring the system back to f24.  But no upgrade.
> A bugzilla check was no less frustrating with no help for the issue.
> Any ideas out there?

Well, that Google Earth package is clearly bad. There's no reason it
should own /usr/bin . It looks like the problem is that it sets a
different mode on it than the `filesystem` package does, which dnf/rpm
will see as a conflict: two packages can contain the same file or
directory without conflict only so long as the file or directory is
identical and has identical properties in both. If they diverge at all,
it becomes a package conflict.

The obvious thing you can do for now is simply remove the google-earth
package; after that the upgrade should work fine. You can then look at
ways to reinstall Google Earth on the upgraded system.

Since the dnf erase command doesn't work, or tries to remove over 211M
of files, do you mean just to remove the directory tree for the
offending package using the rm command?

Les H
devel mailing list -- devel@lists.fedoraproject.org
To unsubscribe send an email to devel-le...@lists.fedoraproject.org

Reply via email to