On 2/23/19 1:02 PM, Chris wrote:
The error:

DEBUG util.py:490:  BUILDSTDERR: Error:
DEBUG util.py:490:  BUILDSTDERR:  Problem: conflicting requests
DEBUG util.py:490:  BUILDSTDERR:   - nothing provides python2-oauthlib needed 
by python2-requests-oauthlib-0.8.0-5.el7.noarch
DEBUG util.py:634:  Child return code was: 1

This same package builds fine using copr (done so here):
https://copr.fedorainfracloud.org/coprs/lead2gold/apprise/

The spec file entry (that works fine for epel7 on Copr) is:
BuildRequires: python2-requests-oauthlib
BuildRequires: python2-oauthlib

This entry just produces an error that all requirements couldn't be met and the scratch build aborts then too.
BuildRequires: python-oauthlib

It appears to be an upstream issue... a missing entry in the python-oauthlib such as:
Provides: python2-oauthlib

I originally thought maybe i should be filing an issue with the oauthlib group, but then if that were the case, it wouldn't have worked perfectly fine on Copr.

Thoughts? Advice?

Chris

Perhaps a link to the koji build might be helpful?


--
Orion Poplawski
Manager of NWRA Technical Systems          720-772-5637
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       or...@nwra.com
Boulder, CO 80301                 https://www.nwra.com/
_______________________________________________
devel mailing list -- devel@lists.fedoraproject.org
To unsubscribe send an email to devel-le...@lists.fedoraproject.org
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: 
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org

Reply via email to