You should be able to copy the .dylib into ~/lib.  For me I embed mono and
call mono_config_parse(mappings_file).  Where mappings_file is the path to a
file that does DLL location mapping.

You can also set turn on logging for mono which can help isolate why it
cannot find the dylib.

$ export MONO_LOG_LEVEL="debug"
$ export MONO_LOG_MASK="dll"
$ mono sample.exe
<lots of output>


On Sat, Jan 23, 2010 at 4:42 AM, Karthikeyan R <>wrote:

> Hi,
> I'm new to Mac and I want to port my .Net application in Mac.
> I found this monobjc and the documentation is really helpful. However still
> I'm unlucky to get a sample application to work on Mac.
> I just followed the steps in Console Application tutorial but still I'm
> getting this error.
> Unhandled Exception: Monobjc.ObjectiveCException: The 'libmonobjc.2.dylib'
> library was not found. Please check that you have correctly installed it.
> ---> System.DllNotFoundException: @executable_path/libmonobjc.2.dylib
> I tried the below steps and got the same error,
> 1. Copied the libmonobjc.*.dylib to Mono.framework lib path at /Library
> 2. Tried with a script file suggested by this site
>     I exported the dist directory to LD_LIBRARY_PATH in that script
> My system details:
> Mono version 2.6.1
> Mac version 10.5.6 (ppc)
> Monobjc 2.0.476.0
> Please let me know what I'm missing.
> One suggestion:
>     In the tutorial
> the picture
> displays only the *.dll not *.dylib files, there is a possibility users can
> miss to read the bullet points (like me).
> Thanks in Advance,
> Karthikeyan R

Reply via email to