It is a PPC only problem. Refer to the release notes
(http://downloads.monobjc.net/Monobjc-2.0.476.0.txt) to see which
platforms have been tested.

Regards, Laurent Etiemble.

2010/1/23 Karthikeyan <karthikms...@gmail.com>:
> Thanks for the reply, the issues you referred is on Mac Intel too? (I'm
> planning to update my Mac Intel's mono version.)
> Karthikeyan R
> -----Original Message-----
> From: laurent.etiem...@gmail.com [mailto:laurent.etiem...@gmail.com] On
> Behalf Of Laurent Etiemble
> Sent: 24 January 2010 00:20
> To: devel
> Subject: Re: [de...@lists.monobjc.net] Need help - libmonobjc.2.dylib not
> found
> Hello,
> Sorry, I have forgot to update the screenshots in the tutorial.
> The *.dylib files must be placed in the MacOS folder of the
> application bundle, in order to be picked up. You can start from the
> NAnt script of the tutorial, or look at the sample applications.
> Note that there are outstanding issues on PPC machines with Mono
> 2.6.1. I suggest to use the Mono, until I got a chance to find
> out why it does not work.
> Regards, Laurent Etiemble.
> 2010/1/23 Karthikeyan R <karthikms...@gmail.com>:
>> Hi,
>> I'm new to Mac and I want to port my .Net application in Mac.
>> I found this monobjc and the documentation is really helpful. However
> still
>> I'm unlucky to get a sample application to work on Mac.
>> I just followed the steps in Console Application tutorial but still I'm
>> getting this error.
>> Unhandled Exception: Monobjc.ObjectiveCException: The 'libmonobjc.2.dylib'
>> library was not found. Please check that you have correctly installed it.
>> ---> System.DllNotFoundException: @executable_path/libmonobjc.2.dylib
>> I tried the below steps and got the same error,
>> 1. Copied the libmonobjc.*.dylib to Mono.framework lib path at /Library
>> 2. Tried with a script file suggested by this site
>>     http://www.mono-project.com/Guide:Running_Mono_Applications
>>     I exported the dist directory to LD_LIBRARY_PATH in that script
>> My system details:
>> Mono version 2.6.1
>> Mac version 10.5.6 (ppc)
>> Monobjc 2.0.476.0
>> Please let me know what I'm missing.
>> One suggestion:
>>     In the tutorial
>> http://www.monobjc.net/index.php?page=console-application the picture
>> displays only the *.dll not *.dylib files, there is a possibility users
> can
>> miss to read the bullet points (like me).
>> Thanks in Advance,
>> Karthikeyan R

Reply via email to