Am Wed, 12 Oct 2016 16:33:11 +0200
schrieb Martin <martin.landsm...@haw-hamburg.de>:
> Am 10/12/2016 um 12:57 PM schrieb Ludwig Knüpfer:
> > Am 12. Oktober 2016 09:48:28 MESZ, schrieb Oleg Hahm
> > <oliver.h...@inria.fr>:
> >> as far I'm concerned it has been an undocumented coding convention so
> >> far to use `int` or `unsigned int` for iterator variables in a loop
> >> instead of
> >> fixed width integer types. Does anybody object to adding this to the coding
> >> conventions explicitly?
> > What about `size_t`?
> +1 for size_t
`size_t` is optimal for every architecture that does not use segmented memory.
The only platform that I know which used segmented memory was 80286, which was
not produced since the mid 90th. According to Wikipedia the last architecture
that used segmented memory died out in 1997.
So, +1 for size_t from me, too.
Freie Universität Berlin
Oertzenweg 19b, 14163 Berlin
Tel.: 030 838 59270
devel mailing list